REMARQUE ! Ce site utilise des cookies et autres technologies similaires.

En utilisant ce site, vous acceptez l'utilisation des cookies. En savoir plus

J'ai compris

Fichiers à installer

 

Fichiers Gstreamer, OpenCV et Qt

 

 

   
      Installer Gstreamer-1.0...    
       
  Plugins Gstreamer à installer voir ci-dessous procédure    
 

gst-plugins-ugly
gst-plugins-base
gst-plugins-good
gst-plugins-bad

gst-libav
gst-plugins-vaapi

rtsp-server

   
       
  Gstreamer installation    
 
sudo apt update

sudo apt-get install --reinstall gstreamer1.0-alsa gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio libgstreamer-plugins-bad1.0-0 libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0 libgstreamer1.0-0

sudo apt-get install gstreamer1.0-vaapi
sudo apt install gir1.2-gst-rtsp-server-1.0
sudo
apt-get install libav-tools
sudo apt-get install libpulse-dev
sudo apt-get install build-essential libgl1-mesa-dev
   
       
 
sudo apt-get install -y --force-yes build-essential autotools-dev automake autoconf \
                                    libtool autopoint libxml2-dev zlib1g-dev libglib2.0-dev \
                                    pkg-config bison flex python3 git gtk-doc-tools libasound2-dev \
                                    libgudev-1.0-dev libxt-dev libvorbis-dev libcdparanoia-dev \
                                    libpango1.0-dev libtheora-dev libvisual-0.4-dev iso-codes \
                                    libgtk-3-dev libraw1394-dev libiec61883-dev libavc1394-dev \
                                    libv4l-dev libcairo2-dev libcaca-dev libspeex-dev libpng-dev \
                                    libshout3-dev libjpeg-dev libaa1-dev libflac-dev libdv4-dev \
                                    libtag1-dev libwavpack-dev libpulse-dev libsoup2.4-dev libbz2-dev \
                                    libcdaudio-dev libdc1394-22-dev ladspa-sdk libass-dev \
                                    libcurl4-gnutls-dev libdca-dev libdvdnav-dev \
                                    libexempi-dev libexif-dev libfaad-dev libgme-dev libgsm1-dev \
                                    libiptcdata0-dev libkate-dev libmimic-dev libmms-dev \
                                    libmodplug-dev libmpcdec-dev libofa0-dev libopus-dev \
                                    librsvg2-dev librtmp-dev \
                                    libsndfile1-dev libsoundtouch-dev libspandsp-dev libx11-dev \
                                    libxvidcore-dev libzbar-dev libzvbi-dev liba52-0.7.4-dev \
                                    libcdio-dev libdvdread-dev libmad0-dev libmp3lame-dev \
                                    libmpeg2-4-dev libopencore-amrnb-dev libopencore-amrwb-dev \
                                    libsidplay1-dev libtwolame-dev libx264-dev libusb-1.0 \
                                    python-gi-dev yasm python3-dev libgirepository1.0-dev
   
    Installer OpenCV-3.3...    
   Script  d' installation Ignacio López Quintero    
 
Une nouvelle version de managerIPs intégrant la technologie "Deep Learning" 
est en cours de développement,il est conseillé d' installer la version openCV 3.3
dans cette optique. L' application a été compilée avec OpenCV 3.3.0
Le script d' installation a été testé sur une version propre de ubuntu-studio-17.10 et s' est déroulé normalement.

Désinstaller si version antérieure.
sudo apt-get autoremove libopencv-dev python-opencv

Important :
Dans le répertoire d' installation, supprimer toute référence ou répertoire d' une ancienne installation OpenCV.

cliquer sur install-opencv.sh et enregistrer le fichier dans un répertoire de votre choix...(~/src/)

Dans ce répertoire click droit ouvrir un terminal et clic droit sur le fichier 
->permission->autoriser
ce fichier à être exécuté comme un programme.
script install-opencv.sh

dans un terminal et dans le répertoire choisi

bash install-opencv.sh
   
  Utiliser sudo cmake-gui si pour une raison mystérieuse l' installation ne se faisait pas.    
 
Décocher ENABLE_PRECOMPILED_HEADER.
Vérifier si une dépendance est manquante et cliquer sur generate.
Dans le répertoire build, sudo make && make install.
   
 

   Installer librairies Qt

   
 
wget http://download.qt.io/official_releases/qt/5.9/5.9.0/qt-opensource-linux-x64-5.9.0.run
chmod +x qt-opensource-linux-x64-5.9.0.run ./qt-opensource-linux-x64-5.9.0.run
sudo apt-get install build-essential
sudo apt-get install libfontconfig1
sudo apt-get install mesa-common-dev
sudo apt-get install libglu1-mesa-dev -y
   
 

Installer arp-scan et/ou nmap

 sudo apt-get install arp-scan
 sudo apt-get install nmap

Si openssl n' est pas installé:
sudo apt
-get install libssl-dev
   
 

ASTUCES :

Placer vous dans le répertoire nManagerIPs et ouvrir un terminal.
Exécuter l' application avec la commande ./nManagerIPs, si une dépendance est manquante,
vous pourrez l' identifier.
ou ldd nManagerIPs.
Installer les librairies manquantes à l' aide de synaptic.

   
       

 

 
 

Free Joomla! template by L.THEME